Ask Experts Questions for FREE Help !
Ask

    What have I blown? A fuse or as relay?

    Asked Mar 29, 2014, 10:23 AM 2 Answers
    I reversed the poles trying to jump start my 2011 troy built bronco mower.

    With a new battery I get nothing. What have I apparently blown? A fuse or as relay ?

    Last edited by talaniman; Mar 29, 2014 at 09:03 PM.
    Search this Question
    Share |
    2 Answers
    ma0641's Avatar
    ma0641 Posts: 15,423, Reputation: 1000
    Uber Member
     
    #2

    Mar 29, 2014, 08:25 PM
    Could be a fuse or fusible link. Look over the owners manual for a wiring diagram.
    Helpful (1)
    jsfocke's Avatar
    jsfocke Posts: 310, Reputation: 37
    Full Member
     
    #3

    Mar 30, 2014, 07:07 AM
    More than likely you have blown the fuse. Follow the red/positive cable from the battery. It will go to the solenoid. The fuse will be within a few inches of the solenoid.
    Helpful

Not your question? Ask your question View similar questions

 

Question Tools Search this Question
Search this Question:

Advanced Search

Add your answer here.


Check out some similar questions!

I just bought a troy built horse lawn mower, how do I start it [ 2 Answers ]

No instructions from Lowe's so I don't know how to make it turn over! Help

Troy built [bronco] riding mower [ 1 Answers ]

I recently bought a tbriding mower.It has a bad vibration when you mash on the pedal to move forward.Even when you shut motor off its has a rattle about it. Is any of this normal for the troy built?

I can't get my troy built rider mower to start [ 3 Answers ]

Hi , I'm a novice at this, so I've done all I can think of. I thought it was the battery, so I recharged it. Still no start. I made sure everything was in the right setting. No luck. I just went out and bought a brand new battery... nothing. I figure I must have the thing hooked up wrong, but...

Troy built pony mower won't start [ 2 Answers ]

Troy built pony riding moerw stalled when the bade bearing frioze up, changed bearinf housind ,blade and belt ,will not even click the starter--where is the blade safety swith located so I can check it ?


View more questions Search