Ask Experts Questions for FREE Help !
Ask
    towerlock's Avatar
    towerlock Posts: 1, Reputation: 1
    New Member
     
    #1

    Nov 22, 2012, 11:29 AM
    No heat
    Flashing red light no heat
    PJmax's Avatar
    PJmax Posts: 70, Reputation: 3
    Junior Member
     
    #2

    Nov 22, 2012, 05:36 PM
    Do we get to guess the make and model of your furnace ?

Not your question? Ask your question View similar questions

 

Question Tools Search this Question
Search this Question:

Advanced Search

Add your answer here.


Check out some similar questions!

Heat pump never turns on, handler blows continuous with no heat except with AUX heat [ 2 Answers ]

10 year old Rheem air handler RHBA-21J8MFCA, 1/3HP, 2.8A. New WeSt Columbia, SC 29170, Model 2HP13L48P-1B, HCFC-22, 4TON. Installed new out of box iN July and AC working splendidly but start-up is "violent" and loud. Installer says I need some sort of "start-up kit". I put off as had planned...

Kenmore dryer won't heat.changed the heat element+thermal fuse.still won't heat [ 1 Answers ]

Kenmore dryer(110.96582100) is 15 years old. Worked great until it stopped heating. Actually it started taking longer and longer to dry the clothes. But now it won't heat at all. I've changed the heating element and thermal fuse. Could it be the thermistor or high limit thermostat? Don't want...

Heat Pump blows 5amp fuse when switching between defrost & back to heat. Them Heat work [ 3 Answers ]

I have a Carrier Heat Pump System. Itís about 5 years old and has functioned OK until this Christmas Eve. One problem is the condensing unit is not kicking back on after it goes into defrost mode. I found a 5AMP fuse blown in the attic unit and once replaced it functioned. At least for a day or two...

Carrier Hvac heat pump with aux/em heat- NO AUX HEAT [ 1 Answers ]

I have tried to install Honeywell 7500d thermostat. I get heat pump heat but no emergency heat although the termostate is calling for it. The installation manual says to see authorized agent if I have a dual 0/b on existing thermostat and another wire is attached to common. As of now, I have ...


View more questions Search