Ask Experts Questions for FREE Help !
Ask
    sanmwa's Avatar
    sanmwa Posts: 1, Reputation: 1
    New Member
     
    #1

    Dec 9, 2009, 10:12 PM
    Speedometer not working on a 1993 camry
    My 1993 camry speedometer and odometer stuck, what is the problem?
    CaptainRich's Avatar
    CaptainRich Posts: 4,490, Reputation: 537
    Cars & Trucks Expert
     
    #2

    Dec 10, 2009, 12:18 PM

    Stuck? Or non-operational?
    If the speedometer is stuck, you'll likely need the speedometer assembly replaced.
    If the speedometer doesn't move from Zero, chances are very good that you need a Vehicle Speed Sensor (VSS).
    Before you do anything, inspect the harness connecting the VSS. Look for damaged or broken wires.
    Has anyone recently worked under the hood of your Camry?

Not your question? Ask your question View similar questions

 

Question Tools Search this Question
Search this Question:

Advanced Search

Add your answer here.


Check out some similar questions!

EFI fuse keeps blowing 1993 toyota camry [ 3 Answers ]

Where can I find the wire diagram for the inside of a engine control module for a 1993 toyota camry I have a short on the EFI fuse

1993 camry won't start [ 3 Answers ]

I change my wires & spare plugs the dist.cap the firing pin and a new batt and my 93 camry still won't start

1993 Camry died while driving! [ 6 Answers ]

Our 1993 Toyota Camry (4 cyl.) just died this morning while DH was driving on the interstate. No warning, nothing. Just cut off. There was still battery power (lights worked well, radio worked well, etc.) and when we try to start it it acts like it wants to start but just isn't doing it. Just...

1993 camry tried everything almost [ 1 Answers ]

My 1993 toyota camry will not start. Will turn over but is getting no fire. Have tried module, distributor, and fuel pump. What's next? Can someone help me?

1993 V6 Toyota Camry won't start [ 1 Answers ]

I just bought this car not running. It turns over fine, has fuel pressure if I jump B and FP at the diagnostic plug, has spark, has correct timing of cams and distributor, has voltage to the injectors, but I think it isn't getting the signal (pulsed ground) from the computer to tell the injectors...


View more questions Search