Ask Experts Questions for FREE Help !
Ask
    hannahsmith3's Avatar
    hannahsmith3 Posts: 1, Reputation: 1
    New Member
     
    #1

    Aug 6, 2005, 05:30 PM
    97 Chevy S-10 heating and idle problem
    I have a 97 Chevy s-10 standard model. Lately it has been overheating where it is pegged on the gage. I wasn't even sure I could get home the other day. What should I do? Also it doesn't idle very well and this has been getting worse lately. I am afraid it is going to quit is traffic and I will be stuck. I replaced the alternator a year ago but it has the same battery could that be a problem? How can I fix the idle problem?
    thebriggsdude's Avatar
    thebriggsdude Posts: 1,096, Reputation: 53
    Ultra Member
     
    #2

    Aug 6, 2005, 06:36 PM
    First off, what I use in my 96 s-10 ls, 10w-30 wieght oil in the summer, calls for 5w-30, but... you don't have to do the same as me, also a 5w-30 synthetic (mobil 1, or amsoil if you can find it) most others claiming full synthetic are group 3 hydro cracked and overpriced conventional oils... and I wouldn't use them... 5w-30 synthetic would do greatly for it, conventional running at the temps you say, has broken down and isn't doing much to protect the engine.. as for the heating problem, whens the last time the radiator was flushed?? Well if it hasn't been for quite a while, have it done, and also have them check the hoses, the radiator for cracks, leaks, etc, and the coolant level, dexcool, 2 bottles for a flush, and have them check the thermostat, the engine should run around 210, lower in cool weather, normal to go a little higher, but should drop back down, so it sounds like its not working, kind of cheap to replace as well... afterwards if your looking for a little cooler operating temps (after its fixed) try some water wetter, pretty good stuff. And as for the rough idling, does it do it all the time? Or after it overheats, if all the time I'd say the injectors are clogged and need some good injector cleaner, or if too bad replaced, if bad... otherwise the plugs ( if they haven't been replaced in a while) sounds like its time for that as well, it deffinently isn't the battery causing the overheating.
    Yankeyboy's Avatar
    Yankeyboy Posts: 1, Reputation: 1
    New Member
     
    #3

    Jun 25, 2008, 04:39 PM
    I had this exact problem with my 97 S-10. I needed a water pump. They leak out the bottom weep hole when they get old. I also lost my serpentine belt one night and had to drive it 10 miles to a parts store to get a new one. That didn't help. Eventually it started to skip. The coolant became fouled with foam indicating the head seal had failed. I bought some of that engine block sealer for $10.00 and it fixed it. You must follow directions exactly for it to work. Takes an overnight repair. That lasted about two years now it is skipping again and number 3 cylinder is missing. I expect it will require a new head. I've lost interest in the truck and currently it's for sale. Only 93K miles and the motor is worn out. tsk tsk. welloh

Not your question? Ask your question View similar questions

 

Question Tools Search this Question
Search this Question:

Advanced Search

Add your answer here.


Check out some similar questions!

1996 Dodge Ram Heating Problem. [ 15 Answers ]

Looking to buy a dodge ram 1500 pickup truck but there is a heating problem. IT HAS NO HEAT. Can anyone help me. The carlot says maybe just a thermostat, well how much work goes into changing a thermostat and what would it cost me to get this replaced? HAS ANYONE HAD ANY major problems with the...

Heating Problem - Kenmore Heavy Duty 60 Series Soft Heat [ 4 Answers ]

My Kenmore Heavy Duty 60 Series Soft Heat Model 96565210will not heat on any setting. The dryer runs normally, it just won't heat at all. We did install a new heat element, and that would not heat up. Any help is appreciated!

Kenmore dryer heating problem [ 3 Answers ]

Iíve read through some of the post but have not actually found this questions. I have a Kenmore dryer that only heats when it is on the high heat/low heat setting. Any ideas?

Heating problem [ 7 Answers ]

I have an oil fired heating system in my house with hot water baseboards. Most of the house is heated fine except for the kitchen and 2nd. Bathroom. These rooms or split off the main trunk feed and return lines but my main bathroom on the second floor is also getting it's heat from this line and...

Heating problem! [ 6 Answers ]

As I was watchingTV this morning I noticed that it was getting hotter and hotter in the house. I looked at the thermostat and it was not calling for heat, but it was still blowing very hot air. I turned the thermostat to the off position and it would not turn off. I tried cycling it through the...


View more questions Search